E4HD: Festplatte wird nur als SDA1 gemountet

Benutzeravatar
Bualicher
NI - VIP
Beiträge: 346
Registriert: Di 12. Apr 2016, 12:22
Has thanked: 4 times
Been thanked: 1 time

Re: E4HD: Festplatte wird nur als SDA1 gemountet

Beitrag von Bualicher »

TangoCash hat geschrieben: Mo 18. Sep 2023, 09:37 Nur mal so als Test:

ändere mal den Aufruf von blkid im Script von "blkid -c /dev/null" in "blkid -w /dev/null -c /dev/null"
Habe ich gemäß Deiner Vorgabe abgeändert:

Code: Alles auswählen

	if which blkid > /dev/null; then
		for i in 1 2 3 4 5 6 7 8 9 10; do # retry 10 times for ssslllooowww devices
			LOGINFO "[$ACTION] trying blkid; try $i/10"
			BLKID=$(blkid -w /dev/null -c /dev/null /dev/$MDEV)
			eval ${BLKID#*:}
			[ -n "${LABEL}${UUID}" ] && break
			sleep 1
		done
Leider auch hier kommt es vor, dass die Symlinks nicht erzeugt werden:

Code: Alles auswählen

Jan  1 00:00:00 E4HD syslog.info syslogd started: BusyBox v1.36.1
Jan  1 00:00:00 E4HD user.info service[299]: running /etc/init.d/sysctl start 
Jan  1 00:00:00 E4HD user.info rcS[115]: Loading e4hd_1.ko 
Jan  1 00:00:00 E4HD user.info rcS[115]: Loading e4hd_2.ko 
Jan  1 00:00:00 E4HD user.info rcS[115]: Loading e4hd_3.ko 
Jan  1 00:00:05 E4HD user.info rcS[115]: Loading e4hd_4.ko 
Jan  1 00:00:12 E4HD user.info service[341]: running /etc/init.d/mdev start 
Jan  1 00:00:12 E4HD user.info mdev[344]: mdev coldplug ...
Jan  1 00:00:13 E4HD user.info mdev-mmcblk[681]: [add] processing mmcblk0p7
Jan  1 00:00:13 E4HD user.info mdev-mmcblk[681]: /dev/mmcblk0p7 already mounted - not mounting again
Jan  1 00:00:13 E4HD user.info mdev-mmcblk[751]: [add] processing mmcblk0p5
Jan  1 00:00:14 E4HD user.info mdev-mmcblk[751]: [add] mounting /dev/mmcblk0p5 to /mnt/mmcblk0p5
Jan  1 00:00:14 E4HD user.info mdev-mmcblk[811]: [add] processing mmcblk0p3
Jan  1 00:00:14 E4HD user.info mdev-mmcblk[811]: [add] mounting /dev/mmcblk0p3 to /mnt/mmcblk0p3
Jan  1 00:00:14 E4HD user.info mdev-mount[856]: [add] mounting /dev/sda1 to /media/sda1
Jan  1 00:00:14 E4HD user.info mdev-mount[856]: [add] mounting /dev/sda1 to /media/sda1; try 1/10
Jan  1 00:00:14 E4HD user.info mdev-mount[856]: try to create symlinks for /dev/sda1 in /media
Jan  1 00:00:14 E4HD user.info mdev-mount[856]: create symlinks: DEVBASE=sda
Jan  1 00:00:14 E4HD user.info mdev-mount[856]: create symlinks: PARTNUM=1
Jan  1 00:00:14 E4HD user.info mdev-mount[856]: [add] trying blkid; try 1/10
Jan  1 00:00:16 E4HD user.info mdev-mount[856]: [add] trying blkid; try 2/10
Jan  1 00:00:17 E4HD user.info mdev-mount[856]: [add] trying blkid; try 3/10
Jan  1 00:00:18 E4HD user.info mdev-mount[856]: [add] trying blkid; try 4/10
Jan  1 00:00:19 E4HD user.info mdev-mount[856]: [add] trying blkid; try 5/10
Jan  1 00:00:20 E4HD user.info mdev-mount[856]: [add] trying blkid; try 6/10
Jan  1 00:00:21 E4HD user.info mdev-mount[856]: [add] trying blkid; try 7/10
Jan  1 00:00:22 E4HD user.info mdev-mount[856]: [add] trying blkid; try 8/10
Jan  1 00:00:23 E4HD user.info mdev-mount[856]: [add] trying blkid; try 9/10
Jan  1 00:00:24 E4HD user.info mdev-mount[856]: [add] trying blkid; try 10/10
Jan  1 00:00:25 E4HD user.info mdev-mount[856]: create symlinks: LABEL=
Jan  1 00:00:25 E4HD user.info mdev-mount[856]: create symlinks: UUID=
Jan  1 00:00:25 E4HD user.info mdev-mount[856]: create symlinks: MODEL=
Jan  1 00:00:25 E4HD user.info mdev-mmcblk[898]: [add] processing mmcblk0p8
Jan  1 00:00:25 E4HD user.info mdev-mmcblk[898]: [add] /dev/mmcblk0p8 is a kernel partition [kernel4] - not mounting.
Jan  1 00:00:25 E4HD user.info mdev-mmcblk[970]: [add] processing mmcblk0p6
Jan  1 00:00:25 E4HD user.info mdev-mmcblk[970]: [add] /dev/mmcblk0p6 is a kernel partition [kernel3] - not mounting.
Jan  1 00:00:25 E4HD user.info mdev-mmcblk[1027]: [add] processing mmcblk0p4
Jan  1 00:00:25 E4HD user.info mdev-mmcblk[1027]: [add] /dev/mmcblk0p4 is a kernel partition [kernel2] - not mounting.
Jan  1 00:00:25 E4HD user.info mdev-mmcblk[1068]: [add] processing mmcblk0p2
Jan  1 00:00:25 E4HD user.info mdev-mmcblk[1068]: [add] /dev/mmcblk0p2 is a kernel partition [kernel1] - not mounting.
Jan  1 00:00:25 E4HD user.info mdev-mmcblk[1093]: [add] processing mmcblk0p9
Jan  1 00:00:25 E4HD user.info mdev-mmcblk[1093]: [add] mounting /dev/mmcblk0p9 to /mnt/mmcblk0p9
Jan  1 00:00:25 E4HD user.info mdev-mount[1185]: drive sda has partitions (sda1); not trying to mount sda
Jan  1 00:00:25 E4HD user.info mdev[344]: scanning /sys/bus/usb/devices/ to help mdev with usb-coldplug
Jan  1 00:00:25 E4HD user.info mdev[344]: usb device /sys/bus/usb/devices/1-0:1.0 found
Jan  1 00:00:25 E4HD user.info mdev[344]: usb device /sys/bus/usb/devices/2-0:1.0 found
Jan  1 00:00:25 E4HD user.info mdev[344]: usb device /sys/bus/usb/devices/2-1.2:1.0 found
Jan  1 00:00:25 E4HD user.info mdev[344]: usb device /sys/bus/usb/devices/2-1:1.0 found
Jan  1 00:00:25 E4HD user.info mdev[344]: usb device /sys/bus/usb/devices/3-0:1.0 found
Jan  1 00:00:25 E4HD user.info mdev[344]: usb device /sys/bus/usb/devices/4-0:1.0 found
Jan  1 00:00:25 E4HD user.info mdev[344]: usb device /sys/bus/usb/devices/5-0:1.0 found
Jan  1 00:00:25 E4HD user.info mdev[344]: usb device /sys/bus/usb/devices/6-0:1.0 found
Jan  1 00:00:25 E4HD user.info mdev[344]: usb device /sys/bus/usb/devices/6-1:1.0 found
Jan  1 00:00:25 E4HD user.info service[1219]: running /etc/init.d/network start 
Jan  1 00:00:25 E4HD user.info mdev-usb[1196]: add 1-0 Linux 4.10.12 ehci_hcd EHCI Host Controller
Jan  1 00:00:25 E4HD user.info mdev-usb[1196]: type 9/0/0
Jan  1 00:00:25 E4HD user.info mdev-usb[1196]: 1-0 HUB Device
Jan  1 00:00:26 E4HD user.info mdev-usb[1242]: add 2-0 Linux 4.10.12 ehci_hcd EHCI Host Controller
Jan  1 00:00:26 E4HD user.info mdev-usb[1242]: type 9/0/0
Jan  1 00:00:26 E4HD user.info mdev-usb[1242]: 2-0 HUB Device
Jan  1 00:00:26 E4HD user.info mdev-usb[1267]: add 2-1.2 Linux-brcmma BRCM OHCI USB2.0
Jan  1 00:00:26 E4HD user.info service[1279]: running /etc/init.d/ntpdate start 
Jan  1 00:00:26 E4HD user.info mdev-usb[1267]: type 2/2/1
Jan  1 00:00:26 E4HD user.info mdev-usb[1267]: 2-1.2 Communications and CDC Control
Jan  1 00:00:26 E4HD user.info mdev-modprobe[1294]: add module usb:v04A3p0101d0200dc00dsc00dp00ic02isc02ip01in00 succeed
Jan  1 00:00:26 E4HD user.info rc[115]: running /etc/rcS.d/S06initfb start
Jan  1 00:00:26 E4HD user.info mdev-usb[1310]: add 2-1 58f 6254
Jan  1 00:00:26 E4HD user.info rc[115]: running /etc/rcS.d/S40coredump start
Jan  1 00:00:26 E4HD user.info mdev-usb[1310]: type 9/0/1
Jan  1 00:00:26 E4HD user.info mdev-usb[1310]: 2-1 HUB Device
Jan  1 00:00:26 E4HD user.info rc[115]: running /etc/rcS.d/S90proc start
Jan  1 00:00:26 E4HD daemon.info init: Entering runlevel: 3
Jan  1 00:00:26 E4HD user.info rc[1346]: running /etc/rc3.d/S01fstab start
Jan  1 00:00:26 E4HD user.info mdev-usb[1344]: add 3-0 Linux 4.10.12 ohci_hcd BRCM OHCI controller
Jan  1 00:00:26 E4HD user.info mdev-usb[1344]: type 9/0/0
Jan  1 00:00:26 E4HD user.info mdev-usb[1344]: 3-0 HUB Device
Jan  1 00:00:26 E4HD user.info rc[1346]: running /etc/rc3.d/S50crond start
Jan  1 00:00:26 E4HD user.info rc[1346]: running /etc/rc3.d/S50inetd start
Jan  1 00:00:26 E4HD user.info rc[1346]: running /etc/rc3.d/S75autofs start
Jan  1 00:00:26 E4HD user.info mdev-usb[1383]: add 4-0 Linux 4.10.12 ohci_hcd BRCM OHCI controller
Jan  1 00:00:26 E4HD user.info mdev-usb[1383]: type 9/0/0
Jan  1 00:00:26 E4HD user.info mdev-usb[1383]: 4-0 HUB Device
Jan  1 00:00:26 E4HD user.info mdev-usb[1410]: add 5-0 Linux 4.10.12 xhci-hcd xHCI Host Controller
Jan  1 00:00:26 E4HD user.info mdev-usb[1410]: type 9/0/1
Jan  1 00:00:26 E4HD user.info mdev-usb[1410]: 5-0 HUB Device
Jan  1 00:00:26 E4HD user.info mdev-usb[1432]: add 6-0 Linux 4.10.12 xhci-hcd xHCI Host Controller
Jan  1 00:00:26 E4HD user.info mdev-usb[1432]: type 9/0/3
Jan  1 00:00:26 E4HD user.info mdev-usb[1432]: 6-0 HUB Device
Jan  1 00:00:26 E4HD user.info mdev-usb[1454]: add 6-1 SABRENT SABRENT
Jan  1 00:00:26 E4HD user.info mdev-usb[1454]: type 8/6/80
Jan  1 00:00:26 E4HD user.info mdev-usb[1454]: 6-1 Mass Storage Interface
Jan  1 00:00:27 E4HD user.info rc[1346]: running /etc/rc3.d/S75dropbear start
Jan  1 00:00:27 E4HD user.info rc[1346]: running /etc/rc3.d/S75inadyn start
Jan  1 00:00:27 E4HD user.info rc[1346]: running /etc/rc3.d/S75irqbalance start
Jan  1 00:00:27 E4HD user.info rc[1346]: running /etc/rc3.d/S75minidlnad start
Jan  1 00:00:27 E4HD user.info rc[1346]: running /etc/rc3.d/S75minisatip start
Jan  1 00:00:27 E4HD user.info rc[1346]: running /etc/rc3.d/S75nfsd start
Jan  1 00:00:27 E4HD daemon.notice rpc.statd[1530]: Version 2.6.2 starting
Jan  1 00:00:27 E4HD daemon.notice sm-notify[1531]: Version 2.6.2 starting
Jan  1 00:00:27 E4HD daemon.notice rpc.statd[1530]: Initializing NSM state
Jan  1 00:00:28 E4HD daemon.notice rpc.mountd[1541]: Version 2.6.2 starting
Jan  1 00:00:28 E4HD user.info rc[1346]: running /etc/rc3.d/S75samba start
Jan  1 00:00:28 E4HD user.info rc[1346]: running /etc/rc3.d/S75udpxy start
Jan  1 00:00:28 E4HD user.info rc[1346]: running /etc/rc3.d/S75ushare start
Jan  1 00:00:28 E4HD user.info rc[1346]: running /etc/rc3.d/S75vsftpd start
Jan  1 00:00:28 E4HD user.info rc[1346]: running /etc/rc3.d/S75xupnpd start
Jan  1 00:00:38 E4HD user.info rc[1346]: running /etc/rc3.d/S80emmrd start
Jan  1 00:00:38 E4HD user.info rc[1346]: running /etc/rc3.d/S80fritzcallmonitor start
Jan  1 00:00:38 E4HD user.info rc[1346]: running /etc/rc3.d/S80openvpn start
Jan  1 00:00:38 E4HD user.info rc[1346]: running /etc/rc3.d/S80plugins-hide start
Jan  1 00:00:38 E4HD user.info rc[1346]: running /etc/rc3.d/S80rcu_switcher start
Jan  1 00:00:38 E4HD user.info rc[1346]: running /etc/rc3.d/S80tuxcald start
Jan  1 00:00:38 E4HD user.info rc[1346]: running /etc/rc3.d/S80tuxmaild start
Jan  1 00:00:38 E4HD user.info rc[1346]: running /etc/rc3.d/S98camd start
Sep 18 17:17:00 E4HD user.info rc[1346]: running /etc/rc3.d/S98user-initscripts start
Sep 18 17:17:00 E4HD user.info S98user-initscripts[1639]: run users initscripts start ...
Sep 18 17:17:00 E4HD user.info rc[1346]: running /etc/rc3.d/S99rc.local start
Sep 18 17:17:01 E4HD user.info neutrino: e4hdultra: The framebuffer device was opened successfully.
Sep 18 17:17:01 E4HD user.info neutrino: e4hdultra: V01: xres: 220, yres 176, vyres: 352, bpp: 16, linelenght: 440
Sep 18 17:17:01 E4HD user.info neutrino: e4hdultra: The framebuffer device was mapped to memory successfully.
Sep 18 17:17:01 E4HD user.info neutrino: e4hdultra: Framebuffer initialized.
Sep 18 17:17:03 E4HD local0.info xupnpd[1767]: ./plugins/xupnpd_youtube.lua:168: bad argument #1 to 'decode' (string expected, got nil)
Ich habe das Gefühl, dass dies bei einem Restart passiert, wenn die Festplatte davor "ausgeschaltet" (Ruhezustand) war.

Ich greife nochmal meinen vor einigen Posts gemachten Vorschlag zur der Überprüfung der Symlinks nach Systemstart und bei Bedarf deren Erstellung auf.
'
Vielen Dank für Eure Antworten

Bualicher
Benutzeravatar
vanhofen
Administrator
Beiträge: 2952
Registriert: Di 5. Apr 2016, 00:05
Has thanked: 12 times
Been thanked: 27 times

Re: E4HD: Festplatte wird nur als SDA1 gemountet

Beitrag von vanhofen »

Der Aufruf von blkid sollte die schlafende Platte wecken. Zumindest war das bei mir der Fall. Vielleicht sind die 10 Sekunden einfach noch zu wenig. Klingt unwahrscheinlich, aber möglich. Mach doch mal bitte aus dem sleep 1 am Ende der Schleife ein sleep 3.
Das ist aber - zugegeben - eine reine Verzweiflungstat.
Benutzeravatar
Bualicher
NI - VIP
Beiträge: 346
Registriert: Di 12. Apr 2016, 12:22
Has thanked: 4 times
Been thanked: 1 time

Re: E4HD: Festplatte wird nur als SDA1 gemountet

Beitrag von Bualicher »

vanhofen hat geschrieben: Mo 18. Sep 2023, 18:27 Der Aufruf von blkid sollte die schlafende Platte wecken. Zumindest war das bei mir der Fall. Vielleicht sind die 10 Sekunden einfach noch zu wenig. Klingt unwahrscheinlich, aber möglich. Mach doch mal bitte aus dem sleep 1 am Ende der Schleife ein sleep 3.
Das ist aber - zugegeben - eine reine Verzweiflungstat.
Auch dies blieb ohne Erfolg. Und zwischenzeitlich bin ich mir sicher, dass es passiert, wenn die Platte zuvor aus war.

Code: Alles auswählen

Jan  1 00:00:00 E4HD syslog.info syslogd started: BusyBox v1.36.1
Jan  1 00:00:00 E4HD user.info service[301]: running /etc/init.d/sysctl start 
Jan  1 00:00:00 E4HD user.info rcS[117]: Loading e4hd_1.ko 
Jan  1 00:00:00 E4HD user.info rcS[117]: Loading e4hd_2.ko 
Jan  1 00:00:00 E4HD user.info rcS[117]: Loading e4hd_3.ko 
Jan  1 00:00:05 E4HD user.info rcS[117]: Loading e4hd_4.ko 
Jan  1 00:00:12 E4HD user.info service[342]: running /etc/init.d/mdev start 
Jan  1 00:00:12 E4HD user.info mdev[345]: mdev coldplug ...
Jan  1 00:00:13 E4HD user.info mdev-mmcblk[682]: [add] processing mmcblk0p7
Jan  1 00:00:13 E4HD user.info mdev-mmcblk[682]: /dev/mmcblk0p7 already mounted - not mounting again
Jan  1 00:00:13 E4HD user.info mdev-mmcblk[752]: [add] processing mmcblk0p5
Jan  1 00:00:14 E4HD user.info mdev-mmcblk[752]: [add] mounting /dev/mmcblk0p5 to /mnt/mmcblk0p5
Jan  1 00:00:14 E4HD user.info mdev-mmcblk[812]: [add] processing mmcblk0p3
Jan  1 00:00:14 E4HD user.info mdev-mmcblk[812]: [add] mounting /dev/mmcblk0p3 to /mnt/mmcblk0p3
Jan  1 00:00:14 E4HD user.info mdev-mount[857]: [add] mounting /dev/sda1 to /media/sda1
Jan  1 00:00:14 E4HD user.info mdev-mount[857]: [add] mounting /dev/sda1 to /media/sda1; try 1/10
Jan  1 00:00:14 E4HD user.info mdev-mount[857]: try to create symlinks for /dev/sda1 in /media
Jan  1 00:00:14 E4HD user.info mdev-mount[857]: create symlinks: DEVBASE=sda
Jan  1 00:00:14 E4HD user.info mdev-mount[857]: create symlinks: PARTNUM=1
Jan  1 00:00:14 E4HD user.info mdev-mount[857]: [add] trying blkid; try 1/10
Jan  1 00:00:18 E4HD user.info mdev-mount[857]: [add] trying blkid; try 2/10
Jan  1 00:00:21 E4HD user.info mdev-mount[857]: [add] trying blkid; try 3/10
Jan  1 00:00:24 E4HD user.info mdev-mount[857]: [add] trying blkid; try 4/10
Jan  1 00:00:27 E4HD user.info mdev-mount[857]: [add] trying blkid; try 5/10
Jan  1 00:00:30 E4HD user.info mdev-mount[857]: [add] trying blkid; try 6/10
Jan  1 00:00:33 E4HD user.info mdev-mount[857]: [add] trying blkid; try 7/10
Jan  1 00:00:36 E4HD user.info mdev-mount[857]: [add] trying blkid; try 8/10
Jan  1 00:00:39 E4HD user.info mdev-mount[857]: [add] trying blkid; try 9/10
Jan  1 00:00:42 E4HD user.info mdev-mount[857]: [add] trying blkid; try 10/10
Jan  1 00:00:45 E4HD user.info mdev-mount[857]: create symlinks: LABEL=
Jan  1 00:00:45 E4HD user.info mdev-mount[857]: create symlinks: UUID=
Jan  1 00:00:45 E4HD user.info mdev-mount[857]: create symlinks: MODEL=
Jan  1 00:00:45 E4HD user.info mdev-mmcblk[898]: [add] processing mmcblk0p8
Jan  1 00:00:45 E4HD user.info mdev-mmcblk[898]: [add] /dev/mmcblk0p8 is a kernel partition [kernel4] - not mounting.
Jan  1 00:00:45 E4HD user.info mdev-mmcblk[970]: [add] processing mmcblk0p6
Jan  1 00:00:45 E4HD user.info mdev-mmcblk[970]: [add] /dev/mmcblk0p6 is a kernel partition [kernel3] - not mounting.
Jan  1 00:00:45 E4HD user.info mdev-mmcblk[1027]: [add] processing mmcblk0p4
Jan  1 00:00:45 E4HD user.info mdev-mmcblk[1027]: [add] /dev/mmcblk0p4 is a kernel partition [kernel2] - not mounting.
Jan  1 00:00:45 E4HD user.info mdev-mmcblk[1068]: [add] processing mmcblk0p2
Jan  1 00:00:45 E4HD user.info mdev-mmcblk[1068]: [add] /dev/mmcblk0p2 is a kernel partition [kernel1] - not mounting.
Jan  1 00:00:45 E4HD user.info mdev-mmcblk[1093]: [add] processing mmcblk0p9
Jan  1 00:00:45 E4HD user.info mdev-mmcblk[1093]: [add] mounting /dev/mmcblk0p9 to /mnt/mmcblk0p9
Jan  1 00:00:45 E4HD user.info mdev-mount[1185]: drive sda has partitions (sda1); not trying to mount sda
Jan  1 00:00:45 E4HD user.info mdev[345]: scanning /sys/bus/usb/devices/ to help mdev with usb-coldplug
Jan  1 00:00:45 E4HD user.info mdev[345]: usb device /sys/bus/usb/devices/1-0:1.0 found
Jan  1 00:00:45 E4HD user.info mdev[345]: usb device /sys/bus/usb/devices/2-0:1.0 found
Jan  1 00:00:45 E4HD user.info mdev[345]: usb device /sys/bus/usb/devices/2-1.2:1.0 found
Jan  1 00:00:45 E4HD user.info mdev[345]: usb device /sys/bus/usb/devices/2-1:1.0 found
Jan  1 00:00:45 E4HD user.info mdev[345]: usb device /sys/bus/usb/devices/3-0:1.0 found
Jan  1 00:00:45 E4HD user.info mdev[345]: usb device /sys/bus/usb/devices/4-0:1.0 found
Jan  1 00:00:45 E4HD user.info mdev[345]: usb device /sys/bus/usb/devices/5-0:1.0 found
Jan  1 00:00:45 E4HD user.info mdev[345]: usb device /sys/bus/usb/devices/6-0:1.0 found
Jan  1 00:00:45 E4HD user.info mdev[345]: usb device /sys/bus/usb/devices/6-1:1.0 found
Jan  1 00:00:45 E4HD user.info service[1219]: running /etc/init.d/network start 
Jan  1 00:00:45 E4HD user.info mdev-usb[1196]: add 1-0 Linux 4.10.12 ehci_hcd EHCI Host Controller
Jan  1 00:00:45 E4HD user.info mdev-usb[1196]: type 9/0/0
Jan  1 00:00:45 E4HD user.info mdev-usb[1196]: 1-0 HUB Device
Jan  1 00:00:46 E4HD user.info mdev-usb[1243]: add 2-0 Linux 4.10.12 ehci_hcd EHCI Host Controller
Jan  1 00:00:46 E4HD user.info mdev-usb[1243]: type 9/0/0
Jan  1 00:00:46 E4HD user.info mdev-usb[1243]: 2-0 HUB Device
Jan  1 00:00:46 E4HD user.info service[1273]: running /etc/init.d/ntpdate start 
Jan  1 00:00:46 E4HD user.info mdev-usb[1268]: add 2-1.2 Linux-brcmma BRCM OHCI USB2.0
Jan  1 00:00:46 E4HD user.info mdev-usb[1268]: type 2/2/1
Jan  1 00:00:46 E4HD user.info mdev-usb[1268]: 2-1.2 Communications and CDC Control
Jan  1 00:00:46 E4HD user.info rc[117]: running /etc/rcS.d/S06initfb start
Jan  1 00:00:46 E4HD user.info mdev-modprobe[1300]: add module usb:v04A3p0101d0200dc00dsc00dp00ic02isc02ip01in00 succeed
Jan  1 00:00:46 E4HD user.info rc[117]: running /etc/rcS.d/S40coredump start
Jan  1 00:00:46 E4HD user.info rc[117]: running /etc/rcS.d/S90proc start
Jan  1 00:00:46 E4HD user.info mdev-usb[1314]: add 2-1 58f 6254
Jan  1 00:00:46 E4HD daemon.info init: Entering runlevel: 3
Jan  1 00:00:46 E4HD user.info mdev-usb[1314]: type 9/0/1
Jan  1 00:00:46 E4HD user.info mdev-usb[1314]: 2-1 HUB Device
Jan  1 00:00:46 E4HD user.info rc[1343]: running /etc/rc3.d/S01fstab start
Jan  1 00:00:46 E4HD user.info rc[1343]: running /etc/rc3.d/S50crond start
Jan  1 00:00:46 E4HD user.info rc[1343]: running /etc/rc3.d/S50inetd start
Jan  1 00:00:46 E4HD user.info mdev-usb[1350]: add 3-0 Linux 4.10.12 ohci_hcd BRCM OHCI controller
Jan  1 00:00:46 E4HD user.info mdev-usb[1350]: type 9/0/0
Jan  1 00:00:46 E4HD user.info mdev-usb[1350]: 3-0 HUB Device
Jan  1 00:00:46 E4HD user.info rc[1343]: running /etc/rc3.d/S75autofs start
Jan  1 00:00:46 E4HD user.info mdev-usb[1388]: add 4-0 Linux 4.10.12 ohci_hcd BRCM OHCI controller
Jan  1 00:00:46 E4HD user.info mdev-usb[1388]: type 9/0/0
Jan  1 00:00:46 E4HD user.info mdev-usb[1388]: 4-0 HUB Device
Jan  1 00:00:46 E4HD user.info mdev-usb[1410]: add 5-0 Linux 4.10.12 xhci-hcd xHCI Host Controller
Jan  1 00:00:46 E4HD user.info mdev-usb[1410]: type 9/0/1
Jan  1 00:00:46 E4HD user.info mdev-usb[1410]: 5-0 HUB Device
Jan  1 00:00:46 E4HD user.info mdev-usb[1432]: add 6-0 Linux 4.10.12 xhci-hcd xHCI Host Controller
Jan  1 00:00:46 E4HD user.info mdev-usb[1432]: type 9/0/3
Jan  1 00:00:46 E4HD user.info mdev-usb[1432]: 6-0 HUB Device
Jan  1 00:00:46 E4HD user.info mdev-usb[1454]: add 6-1 SABRENT SABRENT
Jan  1 00:00:46 E4HD user.info mdev-usb[1454]: type 8/6/80
Jan  1 00:00:46 E4HD user.info mdev-usb[1454]: 6-1 Mass Storage Interface
Jan  1 00:00:47 E4HD user.info rc[1343]: running /etc/rc3.d/S75dropbear start
Jan  1 00:00:47 E4HD user.info rc[1343]: running /etc/rc3.d/S75inadyn start
Jan  1 00:00:47 E4HD user.info rc[1343]: running /etc/rc3.d/S75irqbalance start
Jan  1 00:00:47 E4HD user.info rc[1343]: running /etc/rc3.d/S75minidlnad start
Jan  1 00:00:47 E4HD user.info rc[1343]: running /etc/rc3.d/S75minisatip start
Jan  1 00:00:47 E4HD user.info rc[1343]: running /etc/rc3.d/S75nfsd start
Jan  1 00:00:47 E4HD daemon.notice rpc.statd[1530]: Version 2.6.2 starting
Jan  1 00:00:47 E4HD daemon.notice sm-notify[1531]: Version 2.6.2 starting
Jan  1 00:00:47 E4HD daemon.notice rpc.statd[1530]: Initializing NSM state
Jan  1 00:00:48 E4HD daemon.notice rpc.mountd[1541]: Version 2.6.2 starting
Jan  1 00:00:48 E4HD user.info rc[1343]: running /etc/rc3.d/S75samba start
Jan  1 00:00:48 E4HD user.info rc[1343]: running /etc/rc3.d/S75udpxy start
Jan  1 00:00:48 E4HD user.info rc[1343]: running /etc/rc3.d/S75ushare start
Jan  1 00:00:48 E4HD user.info rc[1343]: running /etc/rc3.d/S75vsftpd start
Jan  1 00:00:48 E4HD user.info rc[1343]: running /etc/rc3.d/S75xupnpd start
Jan  1 00:00:58 E4HD user.info rc[1343]: running /etc/rc3.d/S80emmrd start
Jan  1 00:00:58 E4HD user.info rc[1343]: running /etc/rc3.d/S80fritzcallmonitor start
Jan  1 00:00:58 E4HD user.info rc[1343]: running /etc/rc3.d/S80openvpn start
Jan  1 00:00:58 E4HD user.info rc[1343]: running /etc/rc3.d/S80plugins-hide start
Jan  1 00:00:58 E4HD user.info rc[1343]: running /etc/rc3.d/S80rcu_switcher start
Jan  1 00:00:58 E4HD user.info rc[1343]: running /etc/rc3.d/S80tuxcald start
Jan  1 00:00:58 E4HD user.info rc[1343]: running /etc/rc3.d/S80tuxmaild start
Jan  1 00:00:58 E4HD user.info rc[1343]: running /etc/rc3.d/S98camd start
Sep 18 18:41:00 E4HD user.info rc[1343]: running /etc/rc3.d/S98user-initscripts start
Sep 18 18:41:00 E4HD user.info S98user-initscripts[1639]: run users initscripts start ...
Sep 18 18:41:00 E4HD user.info rc[1343]: running /etc/rc3.d/S99rc.local start
Sep 18 18:41:01 E4HD user.info neutrino: e4hdultra: The framebuffer device was opened successfully.
Sep 18 18:41:01 E4HD user.info neutrino: e4hdultra: V01: xres: 220, yres 176, vyres: 352, bpp: 16, linelenght: 440
Sep 18 18:41:01 E4HD user.info neutrino: e4hdultra: The framebuffer device was mapped to memory successfully.
Sep 18 18:41:01 E4HD user.info neutrino: e4hdultra: Framebuffer initialized.
Sep 18 18:41:03 E4HD local0.info xupnpd[1755]: ./plugins/xupnpd_youtube.lua:168: bad argument #1 to 'decode' (string expected, got nil)
P.S.: kann ich die Platte irgendwie über die Konsole in den Sleep schicken? Das würde mir die lästige Warterei ersparen :smirk:
'
Vielen Dank für Eure Antworten

Bualicher
Benutzeravatar
vanhofen
Administrator
Beiträge: 2952
Registriert: Di 5. Apr 2016, 00:05
Has thanked: 12 times
Been thanked: 27 times

Re: E4HD: Festplatte wird nur als SDA1 gemountet

Beitrag von vanhofen »

Bualicher hat geschrieben: Mo 18. Sep 2023, 18:55 kann ich die Platte irgendwie über die Konsole in den Sleep schicken? Das würde mir die lästige Warterei ersparen :smirk:

Code: Alles auswählen

hd-idle -t sda
Und noch ein anderes mdev-mount-Scrit, welches versucht, die Platte vorher zu wecken. Dieses wakeup.sh haben wir schon seit Ewigkeiten im Image. Ich hatte nur nicht mehr dran gedacht. ^^

Und danke für deine Geduld, Bua.
Dateianhänge
mdev-mount.txt
(3.43 KiB) 195-mal heruntergeladen
Benutzeravatar
jokel
Beiträge: 2517
Registriert: Mi 31. Mär 2021, 14:23
Box: ZGEMMA H7/C
Has thanked: 22 times
Been thanked: 27 times

Re: E4HD: Festplatte wird nur als SDA1 gemountet

Beitrag von jokel »

vanhofen hat geschrieben: Mo 18. Sep 2023, 14:22 Das ist bereits alles mit mdev geregelt. ^^

Und ein Label, was einmal einer Partition gegeben wurde, kann nach einem Reboot nicht einfach weg sein. Das wird schließlich direkt in der Partitionstabelle gespeichert.
so jetzt hat es gefunzt ..

Code: Alles auswählen

[jokel ~]# blkid /dev/sda1
/dev/sda1: UUID="cb2d4613-ec97-4278-b814-d8e51cf5514b" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="dc71a26a-01"
[jokel ~]# tune2fs -L "SSD_H7" /dev/sda1
tune2fs 1.47.0 (5-Feb-2023)
[jokel ~]# blkid /dev/sda1
/dev/sda1: LABEL="SSD_H7" UUID="cb2d4613-ec97-4278-b814-d8e51cf5514b" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="dc71a26a-01"
Benutzeravatar
jokel
Beiträge: 2517
Registriert: Mi 31. Mär 2021, 14:23
Box: ZGEMMA H7/C
Has thanked: 22 times
Been thanked: 27 times

Re: E4HD: Festplatte wird nur als SDA1 gemountet

Beitrag von jokel »

und nach einem reboot .. sieht das jetzt so aus .. :relaxed:
Dateianhänge
Bildschirmfoto zu 2023-09-19 07-25-20.png
Benutzeravatar
Bualicher
NI - VIP
Beiträge: 346
Registriert: Di 12. Apr 2016, 12:22
Has thanked: 4 times
Been thanked: 1 time

Re: E4HD: Festplatte wird nur als SDA1 gemountet

Beitrag von Bualicher »

vanhofen hat geschrieben: Mo 18. Sep 2023, 20:53
Bualicher hat geschrieben: Mo 18. Sep 2023, 18:55 kann ich die Platte irgendwie über die Konsole in den Sleep schicken? Das würde mir die lästige Warterei ersparen :smirk:

Code: Alles auswählen

hd-idle -t sda
Und noch ein anderes mdev-mount-Scrit, welches versucht, die Platte vorher zu wecken. Dieses wakeup.sh haben wir schon seit Ewigkeiten im Image. Ich hatte nur nicht mehr dran gedacht. ^^

Und danke für deine Geduld, Bua.
Vielen Dank.
Mit Deiner neuen Version hat sich etwas geändert. Nur weiß ich nicht was.
Ich habe kurz vor der neuen Version nochmal einen Neustart gemacht und die Symlinks wurden nicht erzeugt. Dann die neue Version und sie wurden erstellt.
Ich konnte den Fehler danach auch nicht mehr provozieren.
Zur Kontrolle habe ich nochmal die alten Versionen versucht und auch dort bekomme ich den Fehler nicht mehr hin. Ich habe jetzt bei bestimmt 50 Neustarts (mit Festplatte schlafen gelegt (Danke für den hd-idle Befehl) oder wirklich lange gewartet, bis das System die Platte schlafen legt) immer die Symlinks bekommen. Teils wirklich Stunden nach letztem Zugriff auf die Platte. Aber wie geschrieben auch mit den Versionen ohne wakeup.sh.
--> ich bekomme den Fehler, mit keiner der ganzen Versionen, nicht mehr hin.
Daher kann ich leider nicht sagen, ob dies jetzt der wakeup.sh zu verdanken war oder diese eine Initialzündung hervorgerufen hat, weil seit dem Start mit dieser Version habe ich den Fehler nicht mehr gesehen.
Ich werde das weiter beobachten und melden, falls sich der Fehler wieder bemerkbar macht.
'
Vielen Dank für Eure Antworten

Bualicher
Benutzeravatar
vanhofen
Administrator
Beiträge: 2952
Registriert: Di 5. Apr 2016, 00:05
Has thanked: 12 times
Been thanked: 27 times

Re: E4HD: Festplatte wird nur als SDA1 gemountet

Beitrag von vanhofen »

OK, auch gut. Danke für deine Tests.

Ich checke die Version mit wakeup.sh heute Abend dann ein. Die macht ja nichts kaputt.
Benutzeravatar
jokel
Beiträge: 2517
Registriert: Mi 31. Mär 2021, 14:23
Box: ZGEMMA H7/C
Has thanked: 22 times
Been thanked: 27 times

Re: E4HD: Festplatte wird nur als SDA1 gemountet

Beitrag von jokel »

vanhofen hat geschrieben: Di 19. Sep 2023, 08:18 OK, auch gut. Danke für deine Tests.

Ich checke die Version mit wakeup.sh heute Abend dann ein. Die macht ja nichts kaputt.
nur für die e4hd oder generell ?
mein image für die h7 ist vom juli .. und label mässig .. wenn ein label vorhanden ist .. wird die platte
diesbezüglich auch gemountet bzw. ein symlink erstellt .. siehe oben
Benutzeravatar
vanhofen
Administrator
Beiträge: 2952
Registriert: Di 5. Apr 2016, 00:05
Has thanked: 12 times
Been thanked: 27 times

Re: E4HD: Festplatte wird nur als SDA1 gemountet

Beitrag von vanhofen »

Das wird für alle Boxen gleich werden.
Benutzeravatar
jokel
Beiträge: 2517
Registriert: Mi 31. Mär 2021, 14:23
Box: ZGEMMA H7/C
Has thanked: 22 times
Been thanked: 27 times

Re: E4HD: Festplatte wird nur als SDA1 gemountet

Beitrag von jokel »

vanhofen hat geschrieben: Di 19. Sep 2023, 10:43 Das wird für alle Boxen gleich werden.
das d.h. der boxen-start verlängert sich um weitere 10 sec. ?
Benutzeravatar
Gorcon
NI - VIP
Beiträge: 2817
Registriert: Mi 13. Apr 2016, 10:55
Box: E2HD, VU+ Uno4kSE, VU+ Ultimate4k
Has thanked: 49 times
Been thanked: 9 times

Re: E4HD: Festplatte wird nur als SDA1 gemountet

Beitrag von Gorcon »

BPanther hat geschrieben: So 17. Sep 2023, 18:56
Gorcon hat geschrieben: So 17. Sep 2023, 08:10Bei meiner SSD kann man das definitiv ausschließen zumal deren Strombedarf deutlich unter jeder mechanischen Festplatte liegt. Ich habe da entsprechende Messungen (Mit Pikanzeigen) gemacht. Bei herkömmlichen Festplatten wäre es aber durchaus möglich.
Da frage ich mich, was Du da für eine SSD hast, denn bei denen ist der Strombedarf in der Regel doppelt so hoch zu einer normalen HDD.
Hatte ich schon geschrieben das die Samsung 950EVO SSDs nur knapp unter 280mA verbrauchen und auch im Piek das nicht mehr wird. Eine Normale HDD verbraucht über 1A beim hochfahren.
auf wieviel ein USB definiert ist übersteigt der Strombedarf diesen definitiv.
Dann hast Du halt eine ungeeignete SSD genommen. Wozu also eine superschnelle nutzen wenn die an einem USB2.0 betrieben wird?!
Screenshot_20230122_105248_com.ruideng.um34c.jpg
Benutzeravatar
vanhofen
Administrator
Beiträge: 2952
Registriert: Di 5. Apr 2016, 00:05
Has thanked: 12 times
Been thanked: 27 times

Re: E4HD: Festplatte wird nur als SDA1 gemountet

Beitrag von vanhofen »

jokel hat geschrieben: Di 19. Sep 2023, 11:01 das d.h. der boxen-start verlängert sich um weitere 10 sec. ?
Nein. Die zweite Warteschleife, die ich eingebaut habe, greift nur, wenn blkid keine Daten liefert.
Und sie kann vermutlich auch wieder raus. Das simple Wakeup-Script tut ja offenbar, was es soll.
Benutzeravatar
jokel
Beiträge: 2517
Registriert: Mi 31. Mär 2021, 14:23
Box: ZGEMMA H7/C
Has thanked: 22 times
Been thanked: 27 times

Re: E4HD: Festplatte wird nur als SDA1 gemountet

Beitrag von jokel »

ich habe mir deinen umbau im bezug mdev angesehen .. einiges ist mir jetzt klar :relaxed:
Das simple Wakeup-Script tut ja offenbar, was es soll.
zumindest werkelt bei mir eine ssd .. die braucht sowas nicht :wink:
Benutzeravatar
Knicko
NI - Team
Beiträge: 774
Registriert: Di 5. Apr 2016, 16:54
Box: Neo, Neo², Zee², AX-HD51, HD60
Has thanked: 13 times
Been thanked: 14 times

Re: E4HD: Festplatte wird nur als SDA1 gemountet

Beitrag von Knicko »

nun ja.
Meine SSD wurde zuverlässig ohne symlinks gemounted. :grin:

Klappt jetzt einwandfrei. :heart_eyes:

Danke hier auch nochmal Bua für seine Tests und logs. Prima. :hugging:

Kann man mal seinen Urlaub genießen. :sunglasses:

L.Gr. Knicko
MAKE NEUTRINO GREAT AGAIN!
Benutzeravatar
jokel
Beiträge: 2517
Registriert: Mi 31. Mär 2021, 14:23
Box: ZGEMMA H7/C
Has thanked: 22 times
Been thanked: 27 times

Re: E4HD: Festplatte wird nur als SDA1 gemountet

Beitrag von jokel »

prösterchen bzw. stösschen .. und einen schönen urlaub auch von mir :laughing:
Benutzeravatar
Gorcon
NI - VIP
Beiträge: 2817
Registriert: Mi 13. Apr 2016, 10:55
Box: E2HD, VU+ Uno4kSE, VU+ Ultimate4k
Has thanked: 49 times
Been thanked: 9 times

Re: E4HD: Festplatte wird nur als SDA1 gemountet

Beitrag von Gorcon »

jokel hat geschrieben: Mi 20. Sep 2023, 10:44 zumindest werkelt bei mir eine ssd .. die braucht sowas nicht :wink:
Jaein, die reagieren genauso auf ein Wake up, nur sind die halt schneller aufgeweckt weil sie keine Schwungmasse bewegen müssen. ;)
Antworten

Zurück zu „Allgemein“